您当前的位置:首页 > 网站建设笔记 >

浏览器版本过低提示更换或升级JS插件

0

时至今日2017年3月11日,不知道还有多少设计师开发者坚持在建设网站时考虑兼容IE6、IE7、IE8版本的浏览器?自从淘宝天猫网站停止支持IE6、IE7、IE8浏览器(见下图所示),身为前端开发人员的我也开始放弃这些老旧的浏览器(IE6-8),感觉如释重负,为什么?因为从此再也不用给这些充满BUG的不安全的不标准的浏览器编写修补代码。

淘宝网提示浏览器版本过低

如若你在帮客户做网站,而你的客户仍在使用旧版本的IE浏览器,这时你会选择怎样解决这个问题?你会选择兼容低版本的IE浏览器吗?(如果是这意味着你需要额外花时间编写修补代码),还是选择不兼容?我的观点是选择后者并效仿淘宝天猫的做法,当用户使用低版本的IE浏览器访问网站时,提示用户使用其他的现代浏览器,让用户知道在这个世界上,有很多功能强大安全性极高且符合标准的浏览器(如Mozilla Firefox、Google Chrome、Safari、360)。通常我的做法是在网站页面底部的<html>结束标签前通过IE条件注释载入一个JS文件(点击下载:浏览器版本过低提示更换或升级JS插件,注意:该JS插件无需基于一些JS库(如jquery)就可以正常单独使用),该文件的作用就是提示用户使用其他的现代浏览器或升级浏览器以获得更好的体验,如以下代码所示:

</body>
<!--在网站页面底部的<html>结束标签前通过IE条件注释载入一个JS文件-->
<!--[if lt IE 9]>
<script type="text/javascript" src="/statics/ljs/client.js"></script>
<![endif]-->
</html>

你可以使用IE8及以下版本的IE浏览器测试,生成的提示信息效果如下图所示:

浏览器版本过低提示

顶部中部底部